Anti-Virus checker/scanner has detected a virus. Is it related to Java?
This article applies to:
- Platform(s):
Windows 8, Windows 7, Vista, Windows XP
- Java version(s):
6.0, 7.0
SYMPTOMS
Malicious applets have been discovered in the Java cache directory. Anti-virus programs have detected such malicious applets in the following directory:
C:\Documents and Settings\<username>\Application Data\Sun\Java\Deployment\cache
CAUSE
Viruses found in this cache directory are not associated with Java that you downloaded and installed from Oracle. A cache directory is a a temporary storage location. When the browser runs an applet or application, Java stores files into its cache directory for better performance. Some examples of the virus reported in the cache directory:
- Trojan.ByteVerify
- Pdfjsc.CR
- Uutecwv.class
- Hieeyfc.class
SOLUTION
If you find one of these malicious applets on your computer, please use an anti-virus program to delete the applet and you can also clean the cache directory manually.
Remove these malicious applets from the Java cache directory by deleting Temporary Internet Files through the Java Control Panel.
Windows XP
- Click on the Start button and then click on the Control Panel option.
- Double click on the Java icon to open the Java Control Panel.
Windows 7, Vista
- Click on the Start button and then click on the Control Panel option.
- In the Control Panel Search enter Java Control Panel.
- Click on the Java icon to open the Java Control Panel.
Windows 8
Use search to find the Control Panel
-
Press Windows logo key + W to open the Search charm to search settings
OR
Drag the Mouse pointer to the bottom-right corner of the screen, then click on the Search icon.
- In the search box enter Java Control Panel
- Click on Java icon to open the Java Control Panel.
Mac OS X 10.7.3 and above
- Click on Apple icon on upper left of screen.
- Go to System Preferences
- Click on the Java icon to access the Java Control Panel.

Delete Temporary Files through the Java Control Panel
- In the Java Control Panel, under the General tab, click Settings under the Temporary Internet Files section.
The Temporary Files Settings dialog box appears.
- Click Delete Files on the Temporary Files Settings dialog.
The Delete Files and Applications dialog box appears.
- Click OK on the Delete Files and Applications dialog. This deletes all the Downloaded Applications and Applets from the cache.
- Click OK on the Temporary Files Settings dialog. If you want to delete a specific application and applet from the cache, click on View Application and View Applet options respectively.
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