Java.com

Download Help

Help Resources


Get Java Installation Help Now

Firefox warning message: Add-ons may be causing problems


This article applies to:
  • Platform(s): Windows 8, Windows 7, Vista, Windows XP, Windows 2000, Windows 2003, Windows 2008 Server, Macintosh OS X
  • Browser(s): Firefox
  • Java version(s): 6.0, 7.0

SYMPTOMS

The following window appears while launching Firefox browser with the warning:
Firefox has determined that the following add-ons are known to cause stability or security problems


CAUSE

Older versions of the Java Deployment Toolkit (DT) and the Java Plugin have been disabled by Firefox. Some Java versions are flagged by Firefox as 'Add-ons may be causing problems'.

If Firefox thinks an add-on is unsafe and can cause a security risk, it will block it from loading.
In case of a soft block Firefox will present a warning message but will allow the user to continue if they wish but with compromised security. In the case of a hard block Firefox will block installation so that the user cannot use this add-on. To resolve this, the user should update to latest version of Java.


SOLUTION

By upgrading to the latest available Java versions for Java 7 releases should resolve the issue.
ยป Update to the latest version of Java 7

If you see the warning message, follow these steps:
  1. Ensure that the Disable box is checked.
  2. Click on Restart Firefox.
  3. Download the latest version of Java..
screen shot 'Firefox has determined that the following add-ons are known to cause stability or security problems'

We think you might also be interested in:

Select Language | About Java | Support | Developers
Privacy | Terms of Use | Trademarks | Disclaimer

Oracle