Java.com

Télécharger Aide

Version imprimable

Comment contrôler les applications et les applets non sécurisés exécutés dans un navigateur Web ?


Cet article s'applique aux éléments suivants:
  • Version(s) de Java: 7.0, 8.0

Java 7u10 a permis de gérer l'exécution des applications Java non sécurisées (c'est-à-dire celles signées par un publicateur inconnu, ou un certificat qui n'est pas émis par une autorité de certification sécurisée), si la page Web en contient. La définition du niveau de sécurité dans le panneau de configuration Java permet de déterminer si les éléments suivants sont appliqués :
  1. Vous recevez une invite avant l'exécution d'une application Java non sécurisée (MEDIUM ou HIGH).
  2. Les applications Java non sécurisées sont bloquées et ne peuvent plus être exécutées (VERY HIGH).

Depuis Java 7 Update 51, les utilisateurs peuvent configurer l'exécution d'applications qui seraient en temps normal bloquées par des contrôles de sécurité. Si la fonctionnalité de liste des sites avec exception est utilisée, l'option sera répertoriée dans le panneau de configuration Java. Pour plus d'informations, reportez-vous à FAQ sur la liste des sites avec exception.

A compter de Java 8 Update 20, le niveau de sécurité Moyen est supprimé du panneau de configuration Java. Seuls les niveaux Elevé et Très élevé sont disponibles.

La liste des sites avec exception propose aux utilisateurs d'autoriser les mêmes applets que celles qui auraient été autorisées en sélectionnant l'option Moyen mais sur une base site par site, réduisant ainsi le risque lié à l'utilisation de paramètres plus permissifs.


Recherche du panneau de configuration Java

» Windows
» Mac OS X

Définition des niveaux de sécurité via le panneau de configuration Java
Activer Java
  1. Dans le panneau de configuration Java, cliquez sur l'onglet Sécurité.
  2. Sélectionnez un niveau de sécurité.
  3. Cliquez sur Appliquer.
  4. Cliquez sur OK pour enregistrer les modifications apportées dans le panneau de configuration Java.

Niveaux de sécurité dans le panneau de configuration Java

Très élevé
Il s'agit du paramètre de niveau de sécurité le plus restrictif. Toutes les applications signées avec un certificat valide et qui incluent l'attribut de droit d'accès dans le manifeste pour le fichier JAR principal peuvent être exécutées avec des invites de sécurité. Toutes les autres applications sont bloquées.

Elevé
Il s'agit du paramètre de niveau de sécurité minimal recommandé (et par défaut). Les applications signées avec un certificat valide ou arrivé à expiration, et qui incluent l'attribut de droit d'accès dans le manifeste pour le fichier JAR principal, peuvent être exécutées avec des invites de sécurité. Les applications peuvent également être exécutées avec des invites de sécurité lorsque le statut de révocation du certificat ne peut pas être vérifié. Toutes les autres applications sont bloquées.

Moyen (supprimé de Java 8 Update 20 et versions ultérieures)
Seules les applications non signées qui exigent tous les droits d'accès sont bloquées. Toutes les autres applications peuvent être exécutées avec des invites de sécurité. La sélection du niveau de sécurité moyen n'est pas recommandée et rend votre ordinateur plus vulnérable si vous exécutez une application malveillante.


Les éléments suivants pourraient également vous intéresser:



Sélectionner une langue | A propos de Java | Support technique | Développeurs
Politique de confidentialité | Conditions d'utilisation | Trademarks | Avis de non-responsabilité

Oracle