Java.com

Download Guida in linea

Versione stampabile

Perché vengono visualizzati i messaggi Aggiornamento Java necessario: La versione corrente di Java è obsoleta o La versione di Java non è sicura?


Questo articolo è relativo a:
  • Versioni Java: 7.0, 7u10+, 8.0

Java 7 Update 10 (7u10) e le versioni più recenti ora includono una funzione che consente di inviare una notifica all'utente quando la versione di Java in uso è obsoleta o sono presenti vulnerabilità note di sicurezza ed è disponibile il download di una versione aggiornata per correggere tali problemi.

Quando si trova una pagina che include un'applicazione Java e la versione di Java in uso è considerata obsoleta, viene visualizzato il messaggio Aggiornamento Java necessario. Si consiglia di fare clic su Aggiorna per aprire la pagina di download del sito java.com per ottenere la versione più recente di Java. Se si sceglie di fare clic su Blocca il plugin Java verrà disabilitato nel browser e le applicazioni Java non potranno essere eseguite nel browser Java fino a quando la versione di Java non viene aggiornata.

Se non si è in grado di completare l'installazione di Java, è possibile che venga riscontrato un problema e si venga reindirizzati al sito java.com quando viene aperta una pagina con un'applicazione Java.

Opzioni disponibili nella finestra di dialogo Aggiornamento Java necessario

Nelle versioni di Java precedenti a Java 7 Update 25 (7u25) viene visualizzato il messaggio La versione di Java non è sicura piuttosto che La versione corrente di Java è obsoleta.

  • Aggiorna
    La selezione di questa opzione consente di utilizzare il browser Web per aprire il sito java.com per ottenere la versione più recente di Java.
  • Blocca
    La selezione di questa opzione consente di bloccare il plugin Java nel browser fino a quando non si esegue l'aggiornamento alla versione più recente di Java.
  • In seguito
    La selezione di questa opzione consente di continuare il caricamento del plugin Java. Le impostazioni di sicurezza indicano se è consentita l'esecuzione dell'applicazione.
  • Non visualizzare più questo messaggio
    Se questa casella di controllo è selezionata, il messaggio Aggiornamento Java necessario non verrà più visualizzato finché non sarà disponibile la release successiva. Gli aggiornamenti Java vengono resi disponibili durante tutto l'anno. Gli aggiornamenti di sicurezza vengono rilasciati almeno 4 volte all'anno. Anche i rilasci non correlati alla sicurezza vengono resi disponibili quando necessario.

Il formato del messaggio varia in base a sistemi operativi.

Windows 7, Windows Vista, Windows 8
Windows 8, Windows 7, Vista - Aggiornamento Java necessario, La versione corrente di Java è obsoleta. Aggiorna (consigliato). Consente di recuperare l'aggiornamento di sicurezza più recente da java.com. Blocca Consente di bloccare l'esecuzione del contenuto Java in questa sessione del browser. In seguito. L'esecuzione continua e il promemoria per l'aggiornamento verrà visualizzato di nuovo in seguito.


Perché vengo sempre reindirizzato al sito java.com quando apro una pagina con un'applicazione Java?

Il continuo reindirizzamento a java.com era un problema noto delle versioni di Java 7u25 e precedenti. Questo problema è stato risolto nella release 7u40 di Java.
Installate la versione più recente di Java
Per impedire il reindirizzamento a java.com, scaricate la versione Java 7u40 o una versione successiva da http://java.com


Perché viene visualizzata la finestra di dialogo 'La versione corrente di Java è obsoleta' se l'opzione Controlla automaticamente la presenza di aggiornamenti è deselezionata nel Pannello di controllo Java?

L'opzione Controlla automaticamente la presenza di aggiornamenti disponibile nel Pannello di controllo Java impedisce solo che venga verificata la presenza di aggiornamenti su base settimanale e mensile. La deselezione di questa opzione non impedirà la visualizzazione della finestra di dialogo se la versione di Java installata è obsoleta.


ULTERIORI INFORMAZIONI TECNICHE

Il JRE scade ogni volta che diventa disponibile una nuova release con correzioni alla vulnerabilità della sicurezza. Gli aggiornamenti di patch critiche, che contengono correzioni alla vulnerabilità della sicurezza, vengono annunciati un anno prima su aggiornamenti di patch critiche, alert di sicurezza e comunicato di terze parti.

Per i sistemi non in grado di raggiungere i server Oracle, un meccanismo secondario determina la data di scadenza del JRE. Dopo che una delle seguenti condizioni viene soddisfatta (la nuova release diventa disponibile o viene raggiunta la data di scadenza), Java fornirà altre avvertenze e promemoria per l'aggiornamento alla versione più recente. Agli utenti che ricevono messaggi relativi alla data di scadenza si consiglia di aggiornare Java alla release più recente. Per ulteriori informazioni, vedere JRE Expire Date. (docs.oracle.com)

Scegli una lingua | Informazioni su Java | Supporto | Sviluppatori
Privacy | Termini e condizioni per l'utilizzo | Marchi | Dichiarazione di non responsabilità

Oracle