Errore 1721: Problema con il pacchetto Windows Installer


Questo articolo è relativo a:
  • Piattaforme: Windows 7, Vista, Windows XP
  • Browser:
  • Versioni Java: 1.5.0, 6.0

SINTOMI

Durante l'installazione di Java 2 Runtime Environment, Standard Edition (JRE), viene visualizzata una finestra con il seguente messaggio di errore: Errore 1721. Problema con il pacchetto Windows Installer. Non è possibile eseguire un programma richiesto per completare l'installazione. Contattare il servizio supporto tecnico o il fornitore del pacchetto.
errore 1721


CAUSA

Al momento, stiamo ricercando l'origine esatta di questo problema.
SOLUZIONE

  1. Durante il processo di installazione, disabilitate/configurate tutti i software antispyware o antivirus nel sistema. Ad esempio: il programma Spybot Search & Destroy o Norton AntiVirus
  2. Controllate se qualche spyware o adware installato nel sistema sta bloccando il completamento del processo di installazione. Per istruzioni dettagliate, visitate:
    FAQ su Adware_Spyware
  3. Controllare se in Componenti aggiuntivi di Installazione applicazioni o Internet Explorer sono presenti voci indesiderate (Strumenti - Opzioni Internet - Programmi -> Gestione componenti aggiuntivi). Se trovate una voce indesiderata, rimuovetela/disabilitatela.
  4. In Windows Vista disabilitate la funzione Controllo account utente per l'account ed eseguite il download/reinstallazione di JRE da:
    Download per l'installazione offline di JRE per Windows
Procedura per disabilitare la funzione Controllo account utente (per utenti Vista):
  1. Fate clic su Start e quindi su Pannello di controllo.
  2. Nel Pannello di controllo fate clic su Account utente.
  3. Nella finestra Account utente fate clic su Account utente.
  4. Nella finestra delle attività dell'account utente fate clic su Attiva o disattiva il controllo dell'account utente.
  5. Se il Controllo account utente è attualmente impostato sulla modalità Approvazione amministratore, viene visualizzato il messaggio Controllo account utente. Fate clic su Continua.
  6. Deselezionate la casella di controllo Controllo account utente per la protezione del computer e quindi fate clic su OK.
  7. Fate clic su Riavvia ora per applicare le modifiche immediatamente oppure su Riavvia in seguito e chiudere la finestra delle attività dell'Account utente.