Java.com

Download Guida in linea

Risorse di assistenza

Il plugin Java non funziona in Firefox dopo l'installazione di Java 7 Update 10 (7u10) e versioni successive.


Questo articolo è relativo a:
  • Browser: Firefox
  • Versioni Java: 7.0

SINTOMI

Al termine dell'installazione di Java 7u10 e versioni successive, viene visualizzato il seguente errore:
Errore: è necessario un plugin per visualizzare questo contenuto. Installare il plugin


CAUSA

Questo errore è dovuto a un conflitto tra Java 7u10 e versioni successive e le installazioni standalone di JavaFX.
Esempio: se sono installati Java 7u5 e JavaFX 2.1.1 e Java viene aggiornato alla versione 7u10, Firefox non è in grado di rilevare l'installazione di Java 7u10.


SOLUZIONE

Per risolvere questo problema, è consigliabile disinstallare tutte le versioni di Java e di JavaFX prima di installare Java 7u10 e versioni successive.
Attenetevi alla seguente procedura per risolvere il problema.
  1. Rimuovete tutte le versioni di Java e di JavaFX mediante il Pannello di controllo per la disinstallazione di Windows.
    Istruzioni sulla disinstallazione di Java.
  2. Eseguite la utility di disinstallazione Microsoft per riparare le chiavi del registro danneggiate che impediscono la disinstallazione completa dei programmi o bloccano le nuove installazioni o gli aggiornamenti.
  3. Scaricate e installate il package dell'Installer non in linea per Windows.

Scegli una lingua | Informazioni su Java | Supporto | Sviluppatori
Privacy | Termini e condizioni per l'utilizzo | Marchi | Disclaimer

Oracle