Java.com

다운로드 도움말

도움말 리소스

Firefox 경고 메시지: 부가 기능으로 인해 문제가 발생할 수 있습니다.


적용 대상::
  • 플랫폼: Windows 8, Windows 7, Vista, Windows XP, Windows 2000, Windows 2003, Windows 2008 Server, Macintosh OS X
  • 브라우저: Firefox
  • Java 버전: 6.0, 7.0

증상

Firefox 브라우저를 시작하는 동안 다음 경고 창이 나타납니다.
Firefox has determined that the following add-ons are known to cause stability or security problems(Firefox가 다음 부가 기능에서 안정성 또는 보안 문제를 일으킬 수 있음을 확인했습니다.)


원인

이전 버전의 Java DT(Deployment Toolkit)와 Java 플러그인이 Firefox에서 사용 안함으로 설정되었습니다. 일부 Java 버전은 Firefox에 의해 'Add-ons may be causing problems(부가 기능으로 인해 문제가 발생할 수 있습니다.)'라는 플래그가 지정됩니다.

부가 기능이 안전하지 않으며 보안 위험을 일으킬 수 있다고 Firefox에서 판단할 경우 로드되지 않도록 차단합니다.
소프트 블록의 경우 Firefox에서 경고 메시지를 표시하지만 사용자가 원할 경우 계속할 수 있습니다. 단, 보안 침해가 발생할 수 있습니다. 하드 블록의 경우 사용자가 해당 부가 기능을 사용하지 못하도록 Firefox에서 설치를 차단합니다. 이 문제를 해결하려면 사용자가 최신 버전의 Java로 업데이트해야 합니다.


해결책

Java 6 및 Java 7 릴리스에 사용 가능한 최신 Java 버전으로 업그레이드하여 문제를 해결해야 합니다.
» 최신 버전의 Java 6로 업데이트
» 최신 버전의 Java 7로 업데이트

경고 메시지가 나타나면 다음 단계를 수행하십시오.
  1. Disable(사용 안함) 상자가 선택되어 있는지 확인합니다.
  2. Restart Firefox(Firefox 재시작)를 누릅니다.
  3. 최신 버전의 Java를 다운로드합니다.

기타 지원 항목:

언어 선택 | Java 정보 | 지원 | 개발자
개인 정보 보호 정책 | 사용 약관 | 등록 상표 | 보증의 부인

Oracle