Java.com

다운로드 도움말

인쇄용 버전

웹 브라우저에서 신뢰할 수 없는 애플릿 또는 응용 프로그램이 실행되는 경우 이를 제어하는 방법은 무엇입니까?


적용 대상:
  • Java 버전: 7.0, 8.0

Java 7u10에서는 신뢰할 수 없는 Java 응용 프로그램(즉, 알 수 없는 게시자가 디지털 방식으로 서명한 응용 프로그램 또는 신뢰할 수 있는 인증 기관에서 발행하지 않은 인증서)이 웹 브라우저에 포함된 경우 이러한 프로그램이 언제, 어떻게 실행되는지를 관리할 수 있는 기능이 도입되었습니다. Java 제어판 내에서 보안 레벨을 설정하면 다음 여부를 결정할 수 있습니다.
  1. 신뢰할 수 없는 Java 응용 프로그램이 실행되기 전에 알림(중간 또는 높음) 또는
  2. 신뢰할 수 없는 Java 응용 프로그램이 차단되어 실행할 수 없음(매우 높음)

Java 7 Update 51부터 최신 보안 방법을 따르지 않는 애플릿의 경우 해당 애플릿을 호스트하는 사이트를 예외 사이트 목록에 포함시키는 방식으로 실행 권한을 부여할 수 있습니다.

Java 8 Update 20부터 Java 제어판에서 [중간] 보안 레벨이 제거되었습니다. [높음] 및 [매우 높음] 레벨만 사용 가능합니다.

예외 사이트 목록을 사용하면 중간 옵션을 선택한 경우에 허용되는 것과 동일한 애플릿을 허용할 수 있지만, 사이트별로 적용되므로 보다 허용적인 설정을 사용하는 데서 발생하는 위험을 최소화할 수 있습니다.


Java 제어판 찾기

» Windows
» Mac OS X

Java 제어판을 통해 보안 레벨 설정

  1. Java 제어판에서 보안 탭을 누릅니다.
  2. 원하는 보안 레벨을 선택합니다.
  3. 적용을 누릅니다.
  4. 확인을 눌러 Java 제어판의 변경 사항을 저장합니다.
Java 제어판 - Java 7
Java 제어판 보안 설정 Java 7


Java 제어판 - Java 8u20 이상 버전
Java 8u20 제어판 보안 탭


Java 제어판의 보안 레벨

매우 높음
가장 제한적인 보안 레벨 설정입니다. 적합한 인증서로 서명되고 기본 JAR 파일에 대한 Manifest에 권한 설정 속성을 포함하는 모든 응용 프로그램을 보안 프롬프트로 실행할 수 있습니다. 기타 모든 응용 프로그램은 차단됩니다.

높음
이 설정은 최소 권장(및 기본) 보안 레벨 설정입니다. 적합한 인증서 또는 만료된 인증서로 서명되고 기본 JAR 파일에 대한 Manifest에 권한 설정 속성을 포함하는 응용 프로그램을 보안 프롬프트로 실행할 수 있습니다. 인증서 철회 상태를 확인할 수 없는 경우에도 응용 프로그램을 보안 프롬프트로 실행할 수 있습니다. 기타 모든 응용 프로그램은 차단됩니다.

중간(Java 8 Update 20 및 이후 버전에서 제거됨)
모든 권한 설정을 요청하는 서명되지 않은 응용 프로그램만 차단됩니다. 기타 모든 응용 프로그램을 보안 프롬프트로 실행할 수 있습니다. 중간 보안 레벨 선택은 권장되지 않으며 악성 응용 프로그램을 실행할 경우 컴퓨터가 더욱 취약해집니다.


다음 사항도 살펴보십시오.:



언어 선택 | Java 정보 | 지원 | 개발자
개인 정보 보호 정책 | 사용 약관 | 등록 상표 | 보증의 부인

Oracle