Java.com

Downloaden Help

Afdrukbare versie

Informatie en systeemvereisten voor installatie en gebruik van Oracle Java op Mac OS X


Dit artikel is van toepassing op:
  • Platform(s): Macintosh OS X
  • Java-versie(s): 7.0

Java versie 7u25 en lager van Oracle zijn door Apple onder OS X gedeactiveerd. Na een update naar de laatste versie kan Java worden uitgevoerd op Mac OS X.
» Laatste Java downloaden

» Kan ik Apple Java 6 herstellen nadat ik Oracle Java heb verwijderd?
» Wat zijn de systeemvereisten voor Java op mijn Mac?
» Waarom kan ik Java 6 voor Mac OS X niet vinden op java.com?
» Kan ik Chrome met Oracle Java op mijn Mac gebruiken?
» Hoe kom ik aan Java voor mijn Mac?
» Hoe weet ik of Java is geïnstalleerd op mijn Mac?
» Hoe installeer ik Java voor mijn Mac?
» Hoe kom ik erachter welke versie van Java ik op mijn Mac heb?
» Hoe activeer ik Java op mijn Mac?
» Hoe wis ik de Java-cache op mijn Mac?
» Hoe werk ik Java bij op mijn Mac?
» Hoe verwijder ik Java van mijn Mac?
» Ik heb geen Mac versie 10.7.3 (Lion) of hoger. Hoe kom ik aan Java voor andere Mac versies?
» Is het veilig om eerdere of oudere versies van Java te installeren?
» Waarom werken applets niet nadat Java is verkregen bij een Apple software-update?
» Waarom is Oracle Java alleen beschikbaar voor Mac OS X 10.7.3 en hoger?
» Kan ik Java installeren op Mac 10.10 (Yosemite)?
» Waarom moet ik na de update naar Yosemite Java opnieuw installeren, nadat ik de nieuwste versie al heb geïnstalleerd?
» De installatie loopt vast bij het automatisch bijwerken. Hoe kan ik aan de laatste versie van Java komen?
» Waarom kan ik Java niet uitvoeren vanaf de opdrachtregel?
» Hoe kan ik ondersteuning krijgen of feedback geven over Java?


Kan ik Apple Java 6 herstellen nadat ik Oracle Java 7 heb verwijderd?

Ja. Raadpleeg de instructies op de Apple website Apple Java 6 herstellen. Als op uw systeem JDK 7 of later is geïnstalleerd en u wilt Apple Java 6 herstellen, moeten deze JDK-versies eerst worden verwijderd. Volg de instructies om JDK te verwijderen.

Wat zijn de systeemvereisten voor Java op mijn Mac?
Vereisten van besturingssysteem:   voor Java 7 en hoger hebt u een Mac met Intel processor en Mac OS X versie 10.7.3 (Lion) of hoger nodig. Op een Mac wordt Java geïnstalleerd voor het hele systeem en voor alle gebruikers. Hiervoor zijn beheerdersrechten vereist. Het is niet mogelijk om Java voor afzonderlijke gebruikers te installeren.
Browservereisten:  
Er is een 64-bits browser (bijvoorbeeld Safari of Firefox) vereist om Oracle Java uit te voeren in Mac OS X. De 64-bits versie van Chrome is een bèta-versie.

Waarom kan ik Java 6 voor Mac OS X niet vinden op java.com?

Voor Java versie 6 en lager levert Apple een eigen versie van Java. Gebruik voor Mac OS X 10.6 en lager de Software Update-functie (beschikbaar in het Apple-menu) om te controleren of u over de recentste versie van Java 6 voor uw Mac beschikt. Voor vragen over Apple Java 6 op de Mac kunt u contact opnemen met Apple Support. Oracle en Java.com ondersteunen alleen Java 7 en hoger en alleen op 64-bits systemen.

Kan ik Chrome met Oracle Java op mijn Mac gebruiken?
Er is een 64-bits browser (bijvoorbeeld Safari of Firefox) vereist om Oracle Java uit te voeren in Mac OS X. De 64-bits versie van Chrome is een bèta-versie.

Hoe kom ik aan Java voor mijn Mac?

U kunt Java downloaden van java.com.

Hoe weet ik of Java is geïnstalleerd op mijn Mac?

Mac OS X 10.6 en lager: Apple Java wordt standaard met Mac OS geïnstalleerd.
Mac OS X 10.7 (Lion) en hoger: Java wordt niet standaard geïnstalleerd met Mac OS X versie 10.7 en hoger. Om de nieuwste Java-versie van Oracle te kunnen gebruiken, moet u Mac OS X 10.7.3 of hoger hebben.
Als u Java 7 of hoger hebt, wordt een Java-pictogram weergegeven onder Systeemvoorkeuren.
Java-versies 6 en lager worden weergegeven in de app voor Java-voorkeuren in de map Applications (Applicaties) > Utilities (Hulpprogramma's) op uw Mac.

Hoe installeer ik Java voor mijn Mac?

Zie Installatie-instructies voor Mac Java.

Hoe kom ik erachter welke versie van Java ik op mijn Mac heb?

Mac OS X 10.7.3 en hoger: klik onder Systeemvoorkeuren op het Java-pictogram om het Java-besturingspaneel te openen waarin uw Java-versie staat vermeld.
Als u onder Systeemvoorkeuren geen Java-pictogram ziet, is Java 7 of hoger niet geïnstalleerd.

Hoe activeer ik Java op mijn Mac?

Wanneer u Oracle Java op uw Mac (Lion en hoger) installeert, is Java standaard actief.
Als u een Java-applicatie uitvoert in de browser, moet u ook eerst controleren of Java is geactiveerd in uw browser.
Raadpleeg voor eerdere versies van Java de ondersteuningswebsite van Apple.

Hoe wis ik de Java-cache op mijn Mac?

Zie De Java-cache wissen op de Mac.

Hoe werk ik Java bij op mijn Mac?

Zie Java bijwerken op de Mac.

Hoe verwijder ik Java van mijn Mac?

Zie Instructies voor het verwijderen van Mac Java.

Ik heb geen Mac-versie 10.7.3 (Lion) of hoger op mijn Mac. Hoe kom ik aan Java voor andere Mac-versies?

Voor Java versie 6 en lager levert Apple een eigen versie van Java. Gebruik de Software-update-functie (beschikbaar in het Apple menu) om te controleren of u over de recentste versie van Apple Java voor uw Mac beschikt.
Gebruikers van Lion Mac OS X 10.7.1 en 10.7.2 moeten een upgrade uitvoeren naar 10.7.3 of hoger, zodat ze de nieuwste Java-versie bij Oracle kunnen ophalen.

Is het veilig om eerdere of oudere versies van Java te installeren?

Oracle raadt gebruikers ten zeerste af oudere versies van Java te gebruiken. Het installeren van oude en niet-ondersteunde versies van Java op uw systeem vormt een ernstig beveiligingsrisico. Door te upgraden naar de nieuwste versie van Java zorgt u ervoor dat Java-applicaties worden uitgevoerd met de meest actuele veiligheids- en prestatieverbeteringen op het systeem. Op de verificatiepagina kunt u bevestigen dat u de nieuwste versie hebt. Als het installeren van een oudere versie van Java absoluut vereist is, moet u eerst de huidige versie verwijderen. Zie de instructies in de veelgestelde vragen over het verwijderen van Mac Java.

Waarom werken applets niet nadat Java is verkregen bij een Apple software-update?

Apple deactiveert de Java-plug-in en Webstart-applicaties als de Java-update wordt uitgevoerd met Software Update. Als in de Java-plug-in bovendien wordt vastgesteld dat een lange periode geen applets zijn uitgevoerd, wordt de Java-plug-in opnieuw gedeactiveerd.

Waarom is Oracle Java alleen beschikbaar voor Mac OS X 10.7.3 en hoger?

De Java Runtime hangt af van de beschikbaarheid van een API (Application Programming Interface). Enkele API's zijn toegevoegd in Mac OS X 10.7.3. Apple heeft geen plannen om deze API's beschikbaar te maken op oudere versies van het Mac OS.

Kan ik Java installeren op Mac OS X 10.10 (Yosemite)?

Ja. Zie Mac OS X 10.10: veelgestelde vragen.

Waarom wordt mij na de update naar Mac OS X 10.10 (Yosemite) gevraagd Java te installeren, als ik de laatste versie van Java al heb geïnstalleerd?

Sommige gebruikers melden dat hun wordt gevraagd Java opnieuw te installeren nadat ze hun systeem hebben bijgewerkt naar Mac 10.10 en de nieuwste versie van Oracle Java hebben geïnstalleerd. Dat komt gewoonlijk doordat een applicatie gebruikmaakt van Java 6 van Apple, dat ook moet worden bijgewerkt. Zie http://support.apple.com/kb/DL1572 voor meer informatie.

De installatie loopt vast tijdens automatisch bijwerken. Hoe kan ik aan de laatste versie van Java komen?

Bij het automatisch bijwerken voor Mac OS X 10.9 (Mavericks) kan het voorkomen dat de installatie vastloopt. Download de laatste versie van Java op de website van java.com.

Waarom werkt java niet wanneer ik het via de opdrachtregel probeer te gebruiken? De Oracle versie van de JRE is geïnstalleerd.

Bij het installeren van een JRE van Oracle worden symlinks van het type java -version niet bijgewerkt en wordt java niet aan het pad toegevoegd. Voor deze functionaliteit moet u de volledige JDK installeren. Zie voor meer informatie: Informatie over Mac opdrachtregel.

Hoe kan ik ondersteuning krijgen voor of feedback geven over Java?

Vul het feedbackformulier in voor het melden van problemen en het geven van feedback voor Java.


Mogelijk bent u ook geïnteresseerd in:



Taal kiezen | Info over Java | Ondersteuning | Ontwikkelaars
Privacy | Voorwaarden voor gebruik | Handelsmerken | Afwijzing van aansprakelijkheid

Oracle