Java.com

Pobieranie Pomoc

Zasoby Pomocy

Dlaczego po awarii oprogramowania Java na pulpicie umieszczane są pliki hs_log_pid?


Artykuł dotyczy:
  • Platformy: Windows 7, Vista, Windows XP, Windows 2000, Windows 2003
  • Wersje oprogramowania Java: 6.0, 7.0

OBJAWY

Do awarii oprogramowania Java dochodzi podczas uruchamiania apletów i aplikacji w przeglądarce. Na pulpicie umieszczany jest wtedy plik tekstowy (z rozszerzeniem .log). Nazwa tego pliku zaczyna się od ciągu hs_err_pid. W pliku tym znajduje się następujący komunikat o błędzie.
Komunikat o błędzie: „An unexpected error has been detected by HotSpot Virtual Machine” (Wirtualna maszyna HotSpot zgłosiła nieoczekiwany błąd).


PRZYCZYNA

Może być wiele przyczyn awaryjnego zamknięcia apletu. Trwa dochodzenie przyczyn tego problemu. Poniżej wymieniono potencjalne przyczyny.
  • Uruchamiany aplet lub aplikacja zawierają błędy programistyczne lub usterki powodujące awaryjne zamknięcie oprogramowania Java.
  • W komputerze może być zainstalowana starsza wersja środowiska Java, które zawiera błędy powodujące awaryjne zamknięcie oprogramowania.

ROZWIĄZANIE

Trwa poszukiwanie przyczyn występowania tego problemu. Można jednak spróbować rozwiązać problem, korzystając z opisanych tutaj rozwiązań.

Uwaga: Pliki dziennika zapisane na pulpicie można bezpiecznie usunąć.

  • Uruchom aplet TestVM, aby sprawdzić, czy środowisko Java jest prawidłowo zainstalowane w systemie. Jeśli aplet uruchamia się, środowisko Java jest zainstalowane i skonfigurowane prawidłowo. Problem może dotyczyć określonego apletu. W takim przypadku należy skontaktować się z administratorem witryny internetowej lub producentem oprogramowania i powiadomić o problemie.
  • Pobierz i zainstaluj najnowszą wersję oprogramowania Java Najnowsza wersja może zawierać uaktualnienia lub poprawki rozwiązujące ten problem.

Wybór języka | Java - informacje | Asysta Techniczna | Programiści
Prywatność | Warunki korzystania | Znaki towarowe | Zastrzeżenie

Oracle