Java.com

Fazer Download Ajuda

Versão para Impressão

Como usar o Java com o browser Google Chrome?


Este artigo aplica-se a:
  • Versão(ões) do Java: Chrome
  • Java version(s): 7.0, 8.0

Suporte a NPAPI pelo Chrome

O plug-in Java para Web browsers conta com a arquitetura de plug-in para várias plataformas NPAPI, que tem sido há muito tempo, e ainda é atualmente, suportada por todos os principais Web browsers. A Google anunciou em setembro de 2013 seus planos para remover do Chrome o suporte a NPAPI "até o final de 2014"; dessa forma, fica efetivamente eliminado o suporte a Silverlight, Java, Facebook Video e outros plug-ins semelhantes baseados em NPAPI. Recentemente, a Google reviu seus planos e agora declara que planeja remover completamente a NPAPI no final de 2015. Como não ficou claro se essas datas ainda serão estendidas ou não, recomendamos enfaticamente que os usuários do Java considerem alternativas ao Chrome assim que possível. Em vez disso, recomendamos o Firefox, o Internet Explorer e o Safari como opções de longo prazo. A partir de abril de 2015, iniciando com a versão do Google Chrome 42, a Google adicionou uma etapa para configurar plug-ins baseados na NPAPI como o Java para execução — consulte a seção Ativando a NPAPI no Chrome Versão 42 e mais recentes abaixo.


Chrome de 64 bits no Windows

A partir do Chrome versão 37, o Chrome está disponível no formato de 64 bits no Windows. Ao executar o Chrome de 64 bits, o usuário também precisa estar com o Java de 64 bits instalado.
» Windows e Java de 64 bits


Java e Chrome no Mac OS X

Um browser de 64 bits é necessário para executar o Oracle Java de 64 bits no Mac OS X. O Chrome de 64 bits para Mac ficou disponível com a Versão 39 do Chrome. Para obter mais informações, consulte Chrome de 64 bits (blog.chromium.org).


Chrome e Linux

Começando com a versão do Chrome 35, o suporte a NPAPI (API do Plug-in do Netscape) foi removido para a plataforma Linux. Para obter mais informações, consulte Chrome e NPAPI (blog.chromium.org).

O Firefox é o browser recomendado para Java no Linux.


Ativando a NPAPI no Chrome Versão 42 e mais recentes

A partir do Chrome Versão 42, uma etapa de configuração adicional é necessária para continuar usando plug-ins da NPAPI.

  1. Em sua barra de URL, informe:
    chrome://flags/#enable-npapi
  2. Clique no linkAtivar da opção de configuração Ativar a NPAPI.
  3. Clique no botãoReiniciar que agora aparece na parte inferior da página de configuração.

Desenvolvedores e administradores de Sistema que buscam maneiras alternativas de suportar usuários do Chrome devem consultar este blog, em particular as seções "Running Web Start applications outside of a browser" e "Additional Deployment Options".


O plug-in do Java precisa de permissão

Se você vir uma mensagem dentro do Chrome informando que o Java (TM) precisa da sua permissão para ser executado, será necessário responder às opções do Chrome para executar os plug-ins na página. As opções variam de acordo com a versão do Chrome.

Ícone de plug-in do Chrome bloqueado (na barra de endereço)

Procure o ícone de plug-in bloqueado na barra de endereço do Chrome. Clicar no ícone exibirá a opção Plug-ins bloqueados nesta página e as opções de plug-in.

  • Clique em Sempre permitir plug-ins em [nome do site] para permitir que os plug-ins (incluindo Java) sejam executados em todas as páginas deste site.
  • Clique em Executar todos os plug-ins desta vez para só permitir que o conteúdo do plug-in na página (incluindo Java) seja executado enquanto você estiver nela.
  • Clique em Continuar bloqueando plug-ins para impedir que os plug-ins sejam executados nesta página.
Barra de mensagem do Chrome
  • Clique em Executar desta vez para só permitir a execução do conteúdo Java na página enquanto você estiver nela.
  • Clicar em Executar sempre neste site para permitir que o Java seja executado em todas as páginas deste site. Você não verá esta mensagem novamente nas páginas deste site.

Além disso, você pode gerenciar permissões por site por meio da opção Gerenciar bloqueio de plug-in.

Plug-in adicional necessário

Se for exibida uma barra de mensagem no Chrome informando que o Java(TM) é necessário para exibir alguns elementos nesta página, clique em Instalar plug-in na barra de mensagem do Chrome ou faça download em java.com.


Plug-in desatualizado

Se for exibida uma barra de mensagem no Chrome informando que o Java(TM) foi bloqueado porque está desatualizado, clique no link Atualizar plug-in na barra de mensagem do Chrome para obter a última versão do Java.


INFORMAÇÕES RELACIONADAS



Selecionar Idioma | Sobre o Java | Suporte | Desenvolvedores
Privacidade | Termos de Uso | Marcas Comerciais | Isenção de Responsabilidade

Oracle