Java.com

Fazer Download Ajuda

Recursos da Ajuda

O plug-in Java não funcionará no Firefox após a instalação do Java 7 Atualização 10 (7u10) e de versões posteriores


Este artigo aplica-se a:
  • Browser(s): Firefox
  • Versão(ões) do Java: 7.0

SINTOMAS

Após a instalação do Java 7u10 e de versões posteriores, o seguinte erro será exibido:
Erro: é necessário um plug-in para exibir este conteúdo. Instalar Plug-in


CAUSA

Isso ocorre devido a um conflito que as versões 7u10 e posteriores do Java apresentam com instalações stand-alone do JavaFX.
Exemplo: se o Java 7u5 e o JavaFX 2.1.1 forem instalados e o Java for atualizado para 7u10, o Firefox não poderá detectar se o Java 7u10 está instalado.


SOLUÇÃO

Para resolver este problema, é recomendável desinstalar todas as versões do Java e do JavaFX antes de instalar o Java 7u10 e versões posteriores.
Siga as etapas abaixo para solucionar este problema.
  1. Remova todas as versões do Java e JavaFX por meio do Painel de Controle de Desinstalação do Windows.
    Instruções sobre desinstalação do Java.
  2. Execute o utilitário de desinstalação da Microsoft para reparar as chaves de registro corrompidas que impedem que programas sejam desinstalados totalmente ou bloqueiam novas instalações e atualizações.
  3. Faça download e instale o pacote do instalador off-line do Windows.

Selecionar Idioma | Sobre o Java | Suporte | Desenvolvedores
Privacidade | Termos de Uso | Marcas Comerciais | Isenção de Responsabilidade

Oracle