Java.com

İndirme Yardım

Yazdırılabilir Sürüm

Java eklentisi, Java yüklendikten sonra Firefox'ta çalışmıyor


Bu makale aşağıdakilerle ilgilidir:
  • Tarayıcılar: Firefox
  • Java sürümleri 7.0, 8.0

Firefox NPAPI desteğini (Java applet'ler için gerekli teknoloji) sınırlıyor

64 bit Firefox

Firefox'un 64 bit sürümü Java dahil, NPAPI eklentilerini desteklemiyor.

Firefox 52 ve üzeri

Firefox 52'nin (yayın tarihi Mart 2017) başlatılmasıyla, eklenti desteği Adobe Flash ile sınırlandırılmıştır. Java, Silverlight ve benzeri diğer NPAPI tabanlı eklentileri etkileyen NPAPI desteğinden vazgeçilmiştir.

Firefox kullanırken Java uygulamalarına erişmede sorun yaşıyorsanız, Oracle bunun yerine Internet Explorer (Windows) ya da Safari (Mac OS X) kullanmanızı önerir. Firefox kullanıcılarını desteklemek için alternatif yollar arayan Geliştiriciler ve Sistem yöneticileri Web Start uygulamalarını başlatma hakkında bilgiler içeren bu web günlüğünü incelemelidirler.

Firefox 52 ESR 32 bit sürümü

Mozilla, özellikle toplu dağıtımlar için genişletilmiş desteğe gerek duyan kuruluşların kullanımına yönelik olarak Firefox'un bir Genişletilmiş Destek Sürümü (ESR) sürümünü sunmaktadır. Sadece Mozilla Firefox 52 ESR 32 bit sürümü Java Applet'lerinin başlatılmasına gereken standartlar tabanlı eklenti desteği teknolojisi desteğini sunmaya devam edecektir. ESR sürümünü kullanıp kullanmadığınızı görmek için Firefox menü öğesini (Yardım -> Hakkında) kontrol edip "ESR" tanımlayıcısını arayın.

Mozilla, Firefox ESR Sürümleri'ni yaklaşık bir yıl koruyacaktır. Halen 32 bit Mozilla Firefox web tarayıcısında Java eklenti teknolojisine bağımlı olan geliştiricilerin ve kullanıcıların farklı bir çözüme geçmeyi göz önünde bulundurması gerekir.

İlgili

» Firefox eklenti desteği (Java Ürün Yönetimi web günlüğü)
» Eklenti Desteği ve Firefox 52 (mozilla.org)
» Firefox'ta NPAPI Eklentileri (mozilla.org)


Firefox 42, Java eklentisi yürütülmeye çalışılırken çöküyor

NOT: Çözüm Firefox 42 için geçerlidir ve Windows Java 8 Güncellemesi 66 Sürüm 18 veya sonraki sürümlerini gerektirir. » İlgili bilgiler için bkz. JDK-8133523.

Çözüm

Bazı seçenekler listelenmiştir. En kolay yöntem ilk olarak belirtilmiştir ve önerilir. Diğer mevcut seçenekler teknik bilgisi olmayan kullanıcılar için önerilmez.

Seçenek 1 (En kolay yöntem)
Firefox tercihlerine dom.ipc.plugins.java.enabled özellik adını ekleyin
  1. Firefox'u başlatın
  2. Adres çubuğuna about:config yazın
  3. Konfigürasyon ayarlarına ilişkin bir Firefox uyarısı görüntülenecek. Firefox uyarısını onayladıktan sonra konfigürasyon tercihlerinin bir listesini göreceksiniz.
  4. Görüntülenen tercihler listesinde herhangi bir yere sağ tıklayın. Yeni ve ardından Boolean öğesini seçin.
  5. Özellik adlarını dom.ipc.plugins.java.enabled olarak ekleyin
    Tercih adını dom.ipc.plugins.java.enabled olarak ekleyin.
  6. Görüntülenen pencerede false öğesini seçin. Ardından Tamam öğesini seçin.
Seçenek 2
Tercih girişiyle "user.js" dosyası oluşturun

Talimatlar, aşağıda listelenen Mozilla referanslarını temel alır.

  1. Firefox profilleri klasörünüzde "user.js" dosyası oluşturmak için bir metin düzenleyici kullanın
  2. Şunu girin:
    user_pref("dom.ipc.plugins.java.enabled", false);
Seçenek 3
"pref.js" dosyasını tercih girişiyle güncelleyin
  1. Mozilla profilleri klasöründe "pref.js" dosyasını bulun
  2. Tercihi bulun ve güncelleyin
    user_pref("dom.ipc.plugins.java.enabled", false);
Mozilla referansları

» http://kb.mozillazine.org/User.js_file
» http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder


Firefox uyarı iletisi: Eklentiler sorunlara yol açabilir

Firefox tarayıcı uyarı ile açılırken aşağıdaki mesaj görüntüleniyor:
Firefox aşağıdaki eklentilerin tutarlılık veya güvenlik sorunlarına yol açtığını belirledi

Neden

Java Deployment Toolkit'in (DT) eski sürümleri ve Java Eklentisi Firefox tarafından devre dışı bırakıldı. Bazı Java sürümleri Firefox tarafından 'Eklentiler sorunlara yol açabilir' olarak işaretlendi.

Firefox bir eklentinin güvenli olmadığını veya güvenlik riski oluşturabileceğini algıladığında eklentinin yüklenmesini engeller. Tercihe bağlı engelleme durumunda Firefox bir uyarı mesajı görüntüler ancak kullanıcının güvenliği riske atarak devam etmesine izin verir. Kesin engelleme durumunda Firefox yüklemeyi engeller ve kullanıcı ilgili eklentiyi kullanamaz. Bunun çözülmesi için kullanıcı tarafından en son Java sürümüne güncelleme yapılmalıdır.

Çözüm

En son Java sürümüne yükseltildiğinde sorun çözülecektir. Uyarı mesajını görüyorsanız aşağıdaki adımları izleyin:

  1. Devre Dışı Bırak kutusunun işaretli olduğundan emin olun.
  2. Firefox'u Yeniden Başlat düğmesine tıklayın.
  3. Java yazılımının en yeni sürümünü indirin.

Java, bağımsız JavaFX yüklemesi nedeniyle Firefox'ta çalışmıyor

Java 7u10 ve sonraki sürümlerin yüklemesi tamamlandıktan sonra aşağıdaki hata görünüyor:
Hata: Bu içeriği görüntülemek için bir eklenti gerekli. Eklentiyi Yükle

Neden

Bunun nedeni, 7u10 ve sonraki Java sürümleri ile bağımsız JavaFX kurulumları arasındaki çakışmadır. Örnek: Java 7u5 ve JavaFX 2.1.1 yüklenirse ve Java güncellenirse, Firefox, yeni yüklenen Java'yı algılayamıyor.

Çözüm
JavaFX'in bağımsız sürümünü kaldırın (Windows)
  1. Windows Kaldırma Denetim Masası aracılığıyla JavaFX ve Java'nın bütün sürümlerini bulun ve kaldırın.
  2. Programların tamamen kaldırılmasını engelleyen veya yeni yükleme ve güncellemeleri engelleyen bozuk kayıt anahtarlarını onarmak için Microsoft kaldırma yardımcı programını çalıştırın.
  3. Java'yı Yeniden Yükleyin

İLGILI BILGILER


İlginizi çekebilecek diğer konular:




Dil Seçin | Java Hakkında | Destek | Geliştiriciler
Gizlilik  | Kullanım Koşulları | Ticari Markalar | Sorumluluğun Reddi

Oracle