Java.com

Descargar Ayuda

Recursos de ayuda

El plugin de Java no funciona en Firefox tras la instalación de Java 7 Update 10 (7u10) y versiones posteriores.


Este artículo se aplica a:
  • Exploradores: Firefox
  • Versiones de Java: 7.0

SÍNTOMAS

Tras terminar de instalar Java 7u10 y versiones posteriores, aparece el siguiente error:
Error: se necesita un plugin para mostrar este contenido. Instale el plugin


CAUSA

Esto se debe al conflicto de las versiones de Java 7u10 y posteriores con las instalaciones independientes de JavaFX.
Ejemplo: si se han instalado Java 7u5 y JavaFX 2.1.1 y si Java se ha actualizado a 7u10, Firefox no puede detectar que se ha instalado Java 7u10.


SOLUCIÓN

Para solucionar este problema, se recomienda desinstalar todas las versiones de Java y JavaFX antes de instalar Java 7u10 y versiones posteriores.
Realice los pasos siguientes para resolver este problema.
  1. Elimine todas las versiones de Java y JavaFX mediante el panel de control de desinstalación de Windows.
    Instrucciones para desinstalar Java.
  2. Ejecute la utilidad de desinstalación de Microsoft para reparar las claves de registro corruptas que evitan que los programas se desinstalen completamente o bloqueen nuevas instalaciones y actualizaciones.
  3. Descargue e instale el paquete del instalador fuera de línea de Windows.

Seleccionar idioma | Acerca de Java | Soporte | Desarrolladores
Privacidad | Condiciones de uso | Marcas Registradas | Descargo de responsabilidad

Oracle