Antivirenprüfung/-scanner hat einen Virus ermittelt. Bezieht er sich auf Java?


Dieser Artikel gilt für:
  • Plattform(en): Windows 8, Windows 7, Vista, Windows XP, Windows 10
  • Java version(en): 7.0, 8.0

SYMPTOME

Im Java-Cacheverzeichnis wurden bösartige Applets festgestellt. Antivirenprogramme haben solch bösartige Applets im folgenden Verzeichnis ermittelt:
C:\Dokumente und Einstellungen\<Benutzername>\Anwendungsdaten\Sun\Java\Deployment\cache


URSACHE

Die in diesem Cacheverzeichnis gefundenen Viren gehören nicht zu der Java-Version, die Sie von Oracle heruntergeladen und installiert haben. Ein Cacheverzeichnis ist ein temporäres Verzeichnis. Wenn der Browser ein Applet oder eine Anwendung ausführt, speichert Java Dateien im Cacheverzeichnis, um die Performance zu verbessern.
Einige Beispiele für den Virus, der im Cacheverzeichnis gemeldet wurde:
  • Exploit:java/CVI-Virus
  • Exploit:Java/CVE-2010-0840
  • Exploit.java.cve-2013-1493
  • CVE-2010-0840
  • Trojan.ByteVerify
  • Pdfjsc.CR
  • Uutecwv.class
  • Hieeyfc.class

LÖSUNG

Wenn Sie eines dieser bösartigen Applets auf Ihrem Computer finden, löschen Sie das Applet mit einem Antivirenprogramm. Sie können das Cacheverzeichnis jedoch auch manuell bereinigen.

Entfernen Sie diese bösartigen Applets aus dem Java-Cacheverzeichnis, indem Sie temporäre Internetdateien über das Java Control Panel löschen.

Java Control Panel suchen

» Windows
» Mac OS X

Temporäre Dateien über das Java Control Panel löschen

  1. Klicken Sie im Java Control Panel unter der Registerkarte Allgemein auf Einstellungen unter dem Abschnitt "Temporäre Internetdateien".
    Das Dialogfeld Einstellungen für temporäre Dateien wird angezeigt.

    Dialogfeld 'Einstellungen für temporäre Dateien'
  2. Klicken Sie auf Dateien löschen im Dialogfeld "Einstellungen für temporäre Dateien".
    Das Dialogfeld Dateien und Anwendungen löschen wird angezeigt.

    Dialogfeld 'Einstellungen für temporäre Dateien'
  3. Klicken Sie im Dialogfeld Dateien und Anwendungen löschen auf OK. Dadurch werden alle heruntergeladenen Anwendungen und Applets aus dem Cache gelöscht.
  4. Klicken Sie im Dialogfeld Einstellungen für temporäre Dateien auf OK. Wenn Sie eine bestimmte Anwendung oder ein bestimmtes Applet aus dem Cache löschen möchten, klicken Sie auf die Optionen zum Anzeigen von Anwendung oder Applets.