Error 1500. Another installation is in progress
This article applies to:
- Platform(s): Windows XP, Windows 7, Windows 8, Windows 10
- Java version(s): Remove Older Versions
SYMPTOMS
During installation of Java from Java.com, a dialog box appears displaying
Error 1500, Another installation is in progress. You must complete that installation before continuing this one.
CAUSE
Error 1500 is a general MSI (Microsoft Installer) install error message resulting into failure of the Java installation process.
The cause of this error could be:
- Two MSI based installers running at the same time. The MSI engine will not allow this.
- In-Progress key left behind if an earlier installation attempt is cancelled forcibly via the Task Manager (Ctrl+Alt+Del) during a transaction/installation process.
SOLUTION 1
Please follow the steps below for resolving this issue.
- Remove any traces of the failed Java installation by uninstalling Java
- Download and install the Windows offline installer package.
SOLUTION 2
- Launch the Windows Start menu.
- In the search box type services.msc and click OK.
- In the Services window that opens up scroll down and look for Windows Installer.
- Select Windows Installer and Right Click and select Properties.
- Click on Startup type drop down and select Disabled.
- Click Apply and then Click OK.
- Now Restart your computer.
- Repeat the above steps 1 through 4.
- In the Windows Installer Properties window, Click on Startup type drop down and select Manual.
- Click Apply and then click OK.
- Download and install the Windows offline installer package.