Error 1500. Another installation is in progress


This article applies to:
  • Platform(s): Windows XP, Windows 7, Windows 8, Windows 10
  • Java version(s): Remove Older Versions

SYMPTOMS

During installation of Java from Java.com, a dialog box appears displaying
Error 1500, Another installation is in progress. You must complete that installation before continuing this one.


CAUSE

Error 1500 is a general MSI (Microsoft Installer) install error message resulting into failure of the Java installation process.

The cause of this error could be:
  1. Two MSI based installers running at the same time. The MSI engine will not allow this.
  2. In-Progress key left behind if an earlier installation attempt is cancelled forcibly via the Task Manager (Ctrl+Alt+Del) during a transaction/installation process.

SOLUTION 1

Please follow the steps below for resolving this issue.
  1. Remove any traces of the failed Java installation by uninstalling Java
  2. Download and install the Windows offline installer package.

SOLUTION 2
  1. Launch the Windows Start menu.
  2. In the search box type services.msc and click OK.
  3. In the Services window that opens up scroll down and look for Windows Installer.
  4. Select Windows Installer and Right Click and select Properties.
  5. Click on Startup type drop down and select Disabled.
  6. Click Apply and then Click OK.
  7. Now Restart your computer.
  8. Repeat the above steps 1 through 4.
  9. In the Windows Installer Properties window, Click on Startup type drop down and select Manual.
  10. Click Apply and then click OK.
  11. Download and install the Windows offline installer package.