El comprobador/explorador antivirus ha detectado un virus. ¿Está relacionado con Java?


Este artículo se aplica a:
  • Plataformas: Windows 8, Windows 7, Vista, Windows XP, Windows 10
  • Versiones de Java: 7.0, 8.0

SÍNTOMAS

Se han descubierto applets maliciosos en el directorio de caché de Java. Los programas antivirus han detectado dichos applets no autorizados en el siguiente directorio:
C:\Documents and Settings\<username>\Application Data\Sun\Java\Deployment\cache


CAUSA

Los virus encontrados en este directorio de caché no están asociados a la aplicación Java que ha descargado de Oracle e instalado. Un directorio de caché es una ubicación de almacenamiento temporal. Cuando el explorador ejecuta un applet o una aplicación, Java almacena archivos en su directorio de caché para mejorar el rendimiento.
Algunos ejemplos de virus indicados en el directorio de caché:
  • Virus Exploit:java/cvi
  • Exploit:Java/CVE-2010-0840
  • Exploit.java.cve-2013-1493
  • CVE-2010-0840
  • Trojan.ByteVerify
  • Pdfjsc.CR
  • Uutecwv.class
  • Hieeyfc.class

SOLUCIÓN

Si encuentra alguno de los applets malintencionados en su computadora, utilice un programa antivirus para suprimirlo o limpie el directorio de memoria caché de forma manual.

Elimine estos applets malintencionados del directorio de la caché de Java. Para ello, suprima los archivos temporales de Internet a través del panel de control de Java.

Búsqueda del panel de control de Java

» Windows
» Mac OS X

Supresión de archivos temporales a través del panel de control de Java

  1. En el panel de control de Java, en el separador General haga clic en Configuración en la sección Archivos temporales de Internet.
    Aparecerá el cuadro de diálogo Configuración de archivos temporales.

    Cuadro de diálogo Configuración de archivos temporales
  2. Haga clic en Suprimir archivos en el cuadro de diálogo Configuración de archivos temporales.
    Se muestra el cuadro de diálogo Suprimir Archivos y Aplicaciones.

    Cuadro de diálogo Configuración de archivos temporales
  3. Haga clic en Aceptar en el cuadro de diálogo Suprimir Archivos y Aplicaciones. Esta acción suprime todas las aplicaciones y applets descargados de la caché.
  4. Haga clic en Aceptar en el cuadro de diálogo Configuración de archivos temporales. Si desea suprimir una aplicación o un applet determinado de la caché, haga clic en las opciones Ver aplicaciones y Ver applets respectivamente.