Java.com

Descargar Ayuda

Versión para imprimir

El plugin de Java no funciona en Firefox tras instalar Java


Este artículo se aplica a:
  • Exploradores: Firefox
  • Versiones de Java: 7.0, 8.0

Firefox limita la compatibilidad con NPAPI (tecnología necesaria para los applets Java)

Firefox de 64 bits

Los complementos de NPAPI, entre otros Java, no están soportados en la versión de 64 bits de Firefox.

Firefox 52 y versiones posteriores

A partir de Firefox 52 (publicado en marzo de 2017), el soporte de plugins quedará limitado a Adobe Flash, dejando de ser compatible con NPAPI, lo cual afecta a los plugins para Java, Silverlight y otros similares basados en dicha arquitectura.

Si tiene problemas para acceder a las aplicaciones Java con Firefox, Oracle recomienda utilizar Internet Explorer (Windows) o Safari (Mac OS X) en su lugar. Este blog sobre ejecución de las aplicaciones Web Start es una opción interesante para desarrolladores y administradores del sistema que estén buscando métodos alternativos de soporte para usuarios de Firefox.

Versión de Firefox 52 ESR de 32 bits

Mozilla ofrece una versión de soporte ampliado (ESR) de Firefox diseñada especialmente para su uso por parte de organizaciones que necesiten soporte ampliado para despliegues masivos. Solo la versión de Mozilla Firefox 52 ESR de 32 bits seguirá ofreciendo soporte para la tecnología de plugins basada en estándares necesaria para iniciar los applets de Java. Para saber si está usando una versión de ESR, compruebe el elemento de menú de Firefox (Ayuda -> Acerca de) y busque el identificador "ESR".

Mozilla mantiene las versiones de Firefox ESR durante un año aproximadamente. Los desarrolladores y usuarios que sigan dependiendo de la tecnología de plugins de Java en el explorador web Mozilla Firefox de 32 bits deberían plantearse migrar a una solución diferente.

Temas relacionados

" Compatibilidad de complementos de Firefox (Blog de gestión de productos Java)
» Compatibilidad de plugins y Firefox 52 (mozilla.org)
» Complementos de NPAPI en Firefox (mozilla.org)


Firefox 42 se bloquea al intentar ejecutar el plugin de Java

NOTA: La solución alternativa se aplica a Firefox 42 y requiere la instalación de Windows Java Versión 8 Actualización 66 Versión 18 o versiones posteriores. » Consulte JDK-8133523 para obtener información relacionada.

Solución alternativa

Se muestran algunas opciones. El primer método es el más sencillo y recomendado. Otras opciones disponibles no están recomendados para usuarios no técnicos.

Opción 1 (método más sencillo)
Añadir nombre de propiedad dom.ipc.plugins.java.enabled en las preferencias de Firefox
  1. Inicie Firefox
  2. Escriba about:config en la barra de direcciones
  3. Se mostrará una advertencia de Firefox sobre los ajustes de configuración. Tras recibir la alerta de Firefox, debe aparecer una lista con las preferencias de configuración.
  4. Haga clic con el botón derecho en cualquier parte de la lista de preferencias mostrada. Seleccione Nuevo y, a continuación, Booleano.
  5. Añada el nombre de propiedad como dom.ipc.plugins.java.enabled
    Añada el nombre de preferencia como dom.ipc.plugins.java.enabled.
  6. En la ventana que se muestra, seleccione false. A continuación, seleccione Aceptar.
Opción 2
Crear archivo "user.js" con entrada de preferencia

Las instrucciones están basadas en las referencias de Mozilla que se indican a continuación.

  1. Use un editor de texto para crear el archivo user.js" en su carpeta de perfiles de Firefox
  2. Añada la entrada:
    user_pref("dom.ipc.plugins.java.enabled", false);
Opción 3
Actualizar el archivo "pref.js" con la entrada de preferencia
  1. Localice el archivo "pref.js" en la carpeta de perfiles de Mozilla
  2. Localice y actualice la preferencia
    user_pref("dom.ipc.plugins.java.enabled", false);
Referencias de Mozilla

» http://kb.mozillazine.org/User.js_file
» http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder


Mensaje de advertencia de Firefox: las aplicaciones complementarias pueden causar problemas

Al abrir el explorador Firefox aparece el siguiente mensaje de advertencia:
Firefox ha determinado que los siguientes complementos pueden causar problemas de estabilidad o seguridad

Causa

Firefox ha desactivado versiones anteriores del toolkit de despliegue de Java (DT) y Java Plugin. Firefox ha marcado algunas versiones de Java con el mensaje 'Los complementos pueden causar problemas'.

Si Firefox considera que un complemento no es seguro y que puede suponer un riesgo para la seguridad, bloqueará su carga. Si se trata de un bloque ligero, Firefox mostrará una advertencia, pero permitirá al usuario continuar si así lo desea, pese a que suponga un riesgo para la seguridad. Si se trata de un bloque pesado, Firefox bloqueará la instalación para que el usuario no pueda utilizar este complemento. Para resolver este problema, el usuario debe actualizar a la última versión de Java.

Solución alternativa

Actualizar a la versión de Java más reciente debería resolver el problema. Si aparece el mensaje de advertencia, siga estos pasos:

  1. Asegúrese de que la casilla Desactivar está activada.
  2. Haga clic en Restart Firefox (Reiniciar Firefox).
  3. Descargue la última versión de Java.

Java no funciona en Firefox debido a la instalación de JavaFX independiente

Tras terminar de instalar Java 7u10 y versiones posteriores, aparece el siguiente error:
Error: se necesita un plugin para mostrar este contenido. Instale el plugin

Causa

Esto podría ser debido al conflicto que las versiones de Java 7u10 y posteriores tienen con las instalaciones independientes de JavaFX. Ejemplo: si se han instalado Java 7u5 y JavaFX 2.1.1 y si Java se ha actualizado, Firefox no puede detectar que se ha instalado una nueva versión de Java.

Solución alternativa
Eliminar versión independiente de JavaFX (Windows)
  1. Busque y elimine todas las versiones de JavaFX y Java con la opción de desinstalación del panel de control de Windows.
  2. Ejecute la utilidad de Microsoft para reparar las claves de registro corruptas que evitan que los programas se desinstalen completamente o bloqueen nuevas instalaciones y actualizaciones.
  3. Vuelva a instalar Java

INFORMACIÓN RELACIONADA


Puede que también le interese:




Seleccionar idioma | Acerca de Java | Soporte | Desarrolladores
Privacidad  | Condiciones de uso | Marcas registradas | Descargo de responsabilidad

Oracle