Java.com

Загрузить Справка

Версия для печати

Подключаемый модуль Java не работает в Firefox после установки Java


Этот раздел касается:
  • Браузеры: Firefox
  • Версии Java: 7.0, 8.0

В браузере Firefox ограничена поддержка технологии NPAPI для апплетов Java

64-разрядная версия Firefox

В 64-разрядной версии Firefox не поддерживаются подключаемые модули NPAPI, включая Java.

Firefox 52 и более поздние версии

В браузере Firefox, начиная с версии 52 (выпуск в марте 2017 года), поддерживается только подключаемый модуль Adobe Flash. Браузер перестает поддерживать технологию NPAPI, что повлияет на работу подключаемых модулей для Java, Silverlight и прочих модулей, основанных на NPAPI.

Если у вас возникают проблемы с доступом к приложениям Java в браузере Firefox, Oracle рекомендует перейти на использование браузера Internet Explorer (Windows) или Safari (Mac OS X). Разработчикам и системным администраторам, которым требуются альтернативные способы поддержки пользователей Firefox, рекомендуем обратиться к этому блогу о запуске приложений Web Start.

Выпуск Firefox 52 ESR, 32-разрядная версия

Mozilla предлагает версию Firefox Extended Support Release (ESR) для организаций, которым требуется дополнительная поддержка для массового развертывания. Только выпуск Mozilla Firefox 52 ESR (32-разрядная версия) сохранит технологию поддержки основанных на стандартах подключаемых модулей, необходимых для запуска приложений Java. Чтобы узнать, используете ли вы выпуск ESR, откройте меню Firefox (Справка -> О программе) и проверьте наличие идентификатора "ESR".

Mozilla продолжит осуществлять поддержку выпусков Firefox ESR в течение приблизительно года. Разработчикам и пользователям, использующим технологию подключаемых модулей Java в 32-разрядной версии Mozilla Firefox, следует рассмотреть переход на другое решение.

См. также

» Поддержка подключаемых модулей в Firefox (блог об управлении продуктами Java)
» Поддержка подключаемых модулей и Firefox 52 (mozilla.org)
» Подключаемые модули NPAPI в Firefox (mozilla.org)


Происходит неожиданный выход из Firefox 42 при попытке выполнить подключаемый модуль Java

Примечание. Существует временное решение для Firefox 42, оно требует наличия Windows Java версии 8 (обновление 66, сборка 18) или более поздних версий. » Дополнительную информацию см. в JDK-8133523.

Временное решение

Ниже приведено несколько вариантов временного решения. Первым приведен самый простейший способ, мы рекомендуем пользователям выполнить именно его. Выполнение остальных способов не рекомендуется для пользователей, не обладающих техническими знаниями.

Вариант 1 (простейший)
Добавление имени свойства dom.ipc.plugins.java.enabled в настройки Firefox
  1. Запустите Firefox.
  2. Введите about:config в строке адреса.
  3. Появится предупреждение Firefox о рисках, связанных с изменением настроек конфигурации. Подтвердите это сообщение, отобразится список настроек конфигурации.
  4. Щелкните правой кнопкой мыши по отображаемому списку настроек. Выберите Создать, затем выберите Логическое.
  5. Добавьте имя свойства dom.ipc.plugins.java.enabled
    Добавьте имя настройки dom.ipc.plugins.java.enabled.
  6. Откроется окно, выберите в нем false. Затем нажмите OK.
Вариант 2
Создание файла "user.js" с записью настройки

Инструкции созданы на основе информации, содержащейся по ссылкам для Mozilla, приведенным ниже.

  1. Для создания файла "user.js" в папке профилей Firefox используйте текстовый редактор
  2. Добавьте запись:
    user_pref("dom.ipc.plugins.java.enabled", false);
Вариант 3
Обновление записи настройки в файле "pref.js"
  1. Перейдите к файлу "pref.js" в папке профилей Mozilla
  2. Найдите и обновите настройку
    user_pref("dom.ipc.plugins.java.enabled", false);
Ссылки на ресурсы для Mozilla

» http://kb.mozillazine.org/User.js_file
» http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder


Предупреждение Firefox: дополнения могут вызывать проблемы

При запуске браузера Firefox отображается следующее сообщение с предупреждением:
Браузер Firefox определил, что следующие дополнения могут вызвать проблемы, связанные с нестабильностью или безопасностью

Причина

Более старые версии пакета Java Deployment Toolkit (DT) и подключаемого модуля Java отключаются браузером Firefox. При наличии некоторых версий Java браузер Firefox может отображать сообщение 'Дополнения могут вызывать проблемы.'

Если Firefox предполагает, что дополнение небезопасно и может представлять риск для системы безопасности, он заблокирует загрузку. В случае мягкой блокировки Firefox отобразит предупреждающее сообщение, но позволит пользователю при необходимости продолжить загрузку. При этом обеспечение безопасности снижается. В случае жесткой блокировки Firefox заблокирует установку, не позволив пользователю использовать это дополнение. Для решения этой проблемы пользователь должен обновить платформу Java до последней версии.

Временное решение

Обновление до последней версии Java поможет устранить эту проблему. Если отображается предупреждение, выполните следующие действия:

  1. Убедитесь, что параметр "Отключено" выбран.
  2. Нажмите кнопку 'Перезапустить Firefox'.
  3. Загрузите новейшую версию Java..

Java не работает в Firefox из-за автономной установки JavaFX

После завершения установки Java 7u10 и более поздних версий отображается следующее сообщение об ошибке:
Ошибка: для отображения данного содержимого требуется подключаемый модуль. Установите подключаемый модуль

Причина

Причиной этого может являться конфликт между Java 7u10 и более поздними версиями и автономными установками JavaFX. Пример: если установлены Java 7u5 и JavaFX 2.1.1, при обновлении Java Firefox не может обнаружить установку новой версии Java.

Временное решение
Удалите автономную версию JavaFX (Windows)
  1. Найдите и удалите все версии JavaFX и Java с помощью панели управления Windows для удаления компонентов.
  2. Запустите утилиту для удаления программ Microsoft, чтобы исправить поврежденные ключи реестра, которые не позволяют полностью удалить программы или блокируют установку и обновление новых программ.
  3. Переустановите Java.

СМОТРИТЕ ТАКЖЕ


Дополнительные ресурсы:




Выбрать язык | О Java | Поддержка | Разработчики | Заявление об ограничении ответственности
Конфиденциальность  | Условия использования | Товарные знаки

Oracle