Java 7 Güncelleme 65 güncellemesi yapıldıktan sonra applet'ler başlatılamıyor.


Bu makale aşağıdakilerle ilgilidir:
  • Platformlar: Windows 7, Windows 8, Windows 10
  • Java sürümleri 7.0, 8.0

BELIRTILER

Java sürüm 7 Güncelleme 65 güncellemesi yapıldıktan sonra Java applet'leri başlatılamıyor.


NEDENI

Bu sorun, Java _arguments parametresini kullanan Java applet'lerinde ve deployment.properties kodunun deployment.javaws.jre.0.args= dosyasında bulunmadığı durumlarda görülmektedir.


ÇÖZÜM

Bu sorun Java 7 Güncelleme 67 (7u67) ile düzeltilmiştir.
En son Java sürümünü indirerek applet yükleme sorununu çözebilirsiniz.

7u65 sürümünü güncelleme imkanı olmayan kullanıcılar için sorunu çözmeye yönelik seçenekler aşağıda sıralanmıştır.

7u65 güncellemesini yüklemiş olan son kullanıcılar için çözüm
Hala 7u65 güncellemesini kullanmakta olan kullanıcılar Java Denetim Masası'nda bazı değişiklikler yaparak bu sorunu çözebilirler.
  1. Windows Başlat menüsüne gidin
  2. Programlar'a tıklayın ve Java programları listesini bulun. Java'yı Yapılandır öğesine tıklayarak Java Denetim Masası'nı başlatın
  3. Java Denetim Masası'nda Java sekmesine tıklayın.
  4. Görüntüle'ye tıklayın
  5. Java 7u65 güncellemesine ait Çalıştırma Zamanı parametrelerine çift tıklayarak düzenleme moduna geçin
  6. Tamam'a ve sonra Uygula'ya tıklayın.
  7. Tamam'a tıklayarak Java Denetim Masası'nı kapatın
çalıştırma zamanı ayarlarını düzenleme
Geliştiriciler ve Sistem Yöneticileri için Çözüm
  1. java_arguments parametresinin applet'in nesne etiketinden kaldırılması, sunucuda sorunun çözülmesini sağlar.
  2. deployment.properties dosyasına şu kodu içeren bir satır ekleyin:
    deployment.javaws.jre.0.args=