错误:无法打开安装程序包。联系应用程序供应商,确认该软件包是否是有效的 Windows Installer 软件包。
本文适用于:
- 平台: Windows 10, Windows 7, Windows 8, Windows XP, Windows Vista
- Java 版本: 7.0, 8.0
问题
Java 安装期间,显示了错误消息:
错误:无法打开安装程序包。
请与应用程序供应商联系以验证该程序包是否是有效的 Windows Installer 程序包。
请与应用程序供应商联系以验证该程序包是否是有效的 Windows Installer 程序包。
原因
有几种可能导致此问题的原因,其中包括:
- 代理服务器要求身份验证
- 网络连接失败
- 下载管理器软件中断了下载过程,例如:断点续传
- TSR(终止并常驻)程序(如 Norton AntiVirus)可能会干扰安装过程
解决方案
目前,我们还不知道问题的根源。但是,我们提供了下列一些解决问题的方法:
-
对于代理服务器验证:检查“Internet 连接代理设置”页面。注:请确保代理身份验证已关闭。
-
网络连接失败:如果网络拥塞或者网络服务提供商的 Internet 连接不稳定,则由于安装文件未能完全下载,有时会导致软件包运行不正常。建议您尝试从我们的网站进行手动下载:Windows 脱机软件包
将软件包保存到某个位置,并在下载完成后启动脱机安装软件包。
- 下载管理器软件:某些下载软件管理器不能正常运行,并且可能中断或降低下载速度。建议您停止使用第三方下载管理器,并启动正常下载。
- TSR:防病毒程序具有阻止下载的选项,除非在下载期间禁用它们。