Error Code 1603: Java Update did not complete.
This article applies to:
- Platform(s): Windows 11, Windows 10, Windows Servers (12, 16, 19, 22)
- Java version(s): 8.0
SYMPTOMS
Java Update/Install process has not completed and an error appears:
Error Code 1603. Java Update did not complete.
Error Code 1603. Java Install did not complete
Error Code 1603. Java Install did not complete
CAUSE
This error, seen during the installation process, indicates that an installation did not complete. The root cause of this error is under investigation.
WORKAROUND
This is a known issue, and we are still investigating the root cause. Meanwhile you can try the following to install Java.
Option 1: Restart your system and uninstall old versions
Restart your system before installing- Once you see the 1603 error, restart your system.
- Download and install the offline installer package.
- When prompted, choose Save in the download dialog box, and save the download package in a convenient place (e.g. save on the desktop).
- Double click on the downloaded installation file to start the installation process.
- If the above instructions fail to resolve the issue, it is recommended that you uninstall all existing Java versions from the system.
- Reboot the system after you uninstall all Java versions, before trying to install.
Option 2: Disable Java content through the Java Control Panel
This option disables Java content in the browser prior to installing.
- Once you see the 1603 error, close the installer.
- Find and launch the Java Control Panel
- Uncheck (de-select) Enable Java content in the browser option
- In the Java Control Panel, click the Security tab.
- Uncheck the option Enable Java content in the browser.
- Click Apply and then OK to confirm the changes.
- Reinstall Java and re-enable Java content in the browser
- Download and install the offline installer package.
- After the installation has completed, re-enable the option to Enable Java content in the browser if you require running Java content in the browser.