Błąd 1500. Inna instalacja jest w toku


Artykuł dotyczy:
  • Platformy: Windows 10, Windows 7, Windows 8, Windows Vista, Windows XP
  • Wersje oprogramowania Java: 8.0

OBJAWY

Podczas instalacji oprogramowania Java z serwisu java.com zostaje wyświetlone okno dialogowe z komunikatem:
Błąd 1500. Inna instalacja jest w toku. Trzeba ją ukończyć przed kontynuowaniem instalacji bieżącej.


PRZYCZYNA

„Błąd 1500” to ogólny komunikat o błędzie instalatora MSI (Microsoft Installer), którego wynikiem jest niepowodzenie procesu instalacji środowiska Java.

Przyczyna tego błędu może być następująca:
  1. Dwa instalatory MSI działają jednocześnie. Mechanizm MSI nie pozwala na to.
  2. Próba wymuszenia anulowania wcześniejszej instalacji przy użyciu Menedżera zadań (Ctrl+Alt+Del) podczas procesu transakcji/instalacji powoduje pozostawienie klucza In-Progress.

ROZWIĄZANIE

Aby rozwiązać ten problem, należy wykonać następujące czynności.
  1. Odinstaluj środowisko Java aby usunąć wszelkie pozostałości po jego nieudanej instalacji.
  2. Pobierz i zainstaluj pakiet instalatora offline dla systemu operacyjnego Windows.